Nouvelle version GLPI 10.0.3 disponible !

GLPI 10.0.3 disponible.

Cette version corrige plusieurs problèmes de sécurité critiques qui ont été découverts récemment. La mise à jour est fortement conseillée!

L’archive de GLPI version 10.0.3 est disponible sur GitHub.
Exceptionnellement, comme nous avons des problèmes de sécurité critiques qui affectent GLPI 9.5, nous publions aussi une archive GLPI 9.5.9.

Vous trouverez ci-dessous la liste des corrections de problemes de securité corrigés dans cette version :

  • XSS via l’API d’enregistrement (CVE-2022-35945)
  • Fuite de données sensibles à travers la page d’authentification (CVE-2022-31143)
  • XSS stockée via la recherche globale (CVE-2022-31187)
  •   Injection de commande par l’intermédiaire d’un script d’une bibliothèque tierce (CVE-2022-35914)
  • Injection SQL via le contrôleur de plugins (CVE-2022-35946)
  •   Authentification par injection SQL (CVE-2022-35947)
  • SSRF aveugle dans les flux RSS et le planning (CVE-2022-36112)

De plus, voici une liste des principaux changements de cette version :

  • Gestion des droits plus précise pour l’inventaire (#12610)
  • Affichage de la dernière donnée inventoriée au niveau des champs verrouillés (#12602)
  • Support de l’ajout d’ordinateurs en temps que machines virtuelles via les règles (#12572)
  • Délégation de la sécurité des cookies à l’administrateur système (#12302)
  • Prévention de l’échec du collecteur quand l’entête d’un email est invalide (#12232)
  • Nombreux correctifs sur l’inventaire réseau

Voir le journal des changements complets pour plus de détails.

Nous remercions toutes les personnes qui ont contribué à cette nouvelle version et plus généralement toutes celles et ceux qui soutiennent régulièrement le projet GLPI.

Découvrez toutes les fonctionnalités GLPI maintenant : https://glpi-project.org/fr/fonctionnalites/

Cordialement.

Formcreator 2.13.0 – version définitive !

Formcreator 2.13.0 version définitive : est compatible avec GLPI 10 uniquement.

Mettez à jour cette nouvelle version, qui est définitive !

revue de la documentation et mises à jour

Bug Fixes

  • cannot delete a ticket from service catalog (acec9bb8)
  • abstractitiltarget: alternative email lost if no requester user (78fd8450)
  • abstracttarget: uuid should not be updated (b1e492d3)
  • checkboxesfield: avoid HTML br tag (c3a60bbb)
  • condition: compatibility with Advanced forms validation (6685b943)
  • descriptinfield: conversion to target requires escaping (b79cfa95)
  • filefield: mandatory check may cause exception (3f711a54)
  • form: PHP warning (844ef96c)
  • form: bad URL when using advanced form validation plugin (adb9fba5)
  • formanswer: grid style updated for current version of gridstack (85b6a686)
  • formanswer: select inherited class if needed (955dc969)
  • formanswer: update gridstack css (70deaa06)
  • glpiselectfield: missing entity restrict (40c9ab73)
  • install: prevent useless warnings (001d12f5)
  • install: use modern settings for tables (f04e4181)
  • issue: remove duplicate item in status dropdown (27f9f313)
  • ldapselectfield: log LDAP error instead of showing it to user (e170dc6f)
  • ldapselectfield: no translation for items (d170c79c)
  • targetticket: prevent exception in inconsistent target ticket (ba6ed88e)
  • textarea: on change event broken (9fb70edb)
  • textarea: rn chars added between lines (66571b80)
  • textarea, entityconfig: embedded image question description (#2901) (0d78db1a)
  • textareafield: embedded image upload broken (d58075cd)
  • textareafield: missing escape before compare (ba78e935)

Fonctionnalités

  • formanswer: order formanswers by date desc (7fdeda51)
  • ldapselectfield: lazy loading (bffcb5b7)

Aide / Contribution nécessaire
Mises à jour des paramètres régionaux : certaines langues n’ont pas de mainteneur ou sont en retard (beaucoup de contenu non traduit). Merci de contribuer sur Transifex.

Consultez le journal des modifications et téléchargez

Découvrez encore plus de fonctionnalités GLPI : https://glpi-project.org/fr/fonctionnalites/

Nouveau partenaire Silver : KING ICT

GLPI partenaires : Nous sommes heureux d’annoncer notre nouveau Partenaire Silver en Croatie – KING ICT.

KING ICT est un intégrateur de systèmes spécialisé dans les solutions TIC avancées qui influent positivement dans le business et la société. Basés sur les nouvelles technologies et le cloud.

Dans le monde de la technologie, c’est un principe de construire des produits numériques prenant qui peuvent être utilisés dans les smartphones.

Ils facilitent les opérations et créent de la valeur ajoutée pour leurs clients, animées par la volonté de construire ensemble un avenir connecté et numérique. Leurs clients viennent de différentes horizons, telles que les transports, les énergies, l’agricultures, la santé, l’éducation, la justice, le commerce, la finance et les télécommunications.

Parmi de nombreuses solutions, KING ICT propose :

• Développement et gestion d’application;
• Applications Métier & Conseil;
• Infrastructure informatique moderne;
• La cyber-sécurité;
• Services informatiques et gestion du lieu de travail;
• Systèmes de sécurité physique.

Website: https://king-ict.com/

Nous sommes ravis que la solution GLPI ITSM soit de plus en plus représentée dans le monde entier et notre service d’abonnement GLPI Network (notre support offre la garantie de l’éditeur, afin que les utilisateurs puissent être sûrs d’obtenir une aide professionnelle, des corrections de bugs et un engagement). Cette offre sera disponible pour davantage de clients via nos nouveaux partenaires.

Notre vaste réseau de partenaires est toujours ouvert à de nouvelles collaborations. Si vous souhaitez représenter l’un de nos produits dans votre pays, contactez-nous: https://glpi-project.org/fr/contact/

Être partenaire, c’est :
• Avoir un accès direct à l’expertise technologique de Teclib;
• Obtenez des remises spéciaux;
• Accédez au support officiel;
• De nombreux autres outils qui vous aideront à gagner plus de clients et à accroître votre
réputation sur le marché en ajoutant l’ITSM Open Source à votre portefeuille.

Découvrez tous les avantages d’être partenaire ici : https://glpi-project.org/fr/partenairesofficiels/

Formcreator 2.12.4

 

Formcreator 2.12.4 : Nous sommes heureux d’annoncer la version 2.12.4 des corrections de bogues de Formcreator. Lisez notre article de blog et regardez la video pour obtenir plus d’informations.

 

Bug Fixes Formcreator 2.12.4

 

  • ajax calls converted into post
  • convert GET requests to post
  • redirection to wrong ticket in some cases (
  • remove compiled css
  • strict JS code triggers warnings
  • form: PHP warning when displaying form’s historical
  • form: php warning – unitialized var
  • form: run conditions for admins
  • form: store itemtype in DOM
  • formanswer: loss of answers upon valdiation
  • issue: better definition of comment search options
  • issue: better redirection
  • issue: redirection when multiple tickets
  • ldapfield: non latin char escaping
  • linker: inverted arguments in method call
  • question: empty name section unavailable
  • question: show error message on deletion failure
  • question: show error message on deletion failure
  • question: show error toast when editing a question fails
  • section: order lost after section deletion
  • targetticket: do not force request type

 

Fonctionnalités

 

  • category: show parent label in back pseudo-item

 

DOWNLOAD: CLICK THIS LINK

 

Formcreator 2.12.2

Le plugin Formcreator pour GLPI est un plugin qui permet de créer des formulaires personnalisés d’accès facile et aussi un ou plusieurs tickets ou modifications lorsque le formulaire est rempli. Aujourd’hui nous sommes heureux d’annoncer la sortie du plugin Formcreator version 2.12.2.

Vous voulez en savoir plus sur son fonctionnement ? Trouvez la réponse dans notre article de blog.

Veuillez accéder au journal des modifications ici : cliquez-ici

Lien de téléchargement : cliquez-ici

Aide / Contribution nécessaire : 

Mises à jour des paramètres régionaux : certaines langues n’ont pas de responsable ou ne sont pas mis à jour (beaucoup de contenu non traduit). Merci, de contribuer sur Transifex.
Documentation revus et mises à jour disponibles.

Formcreator 2.12.1 (bugfixes)

Une nouvelle version de corrections Formcreator est disponible : version 2.12.1. Cette version est compatible avec GLPI 9.5.5 uniquement. La prise en charge de GLPI 9.5.4 et des versions antérieur a été abandonnée, veuillez lire les notes de la version 2.11.3 pour en connaître la raison.

Veuillez accéder au journal des modifications ici : cliquez-ici

Lien de téléchargement : cliquez-ici

Aide / Contribution nécessaire

Mises à jour des paramètres régionaux : certaines langues n’ont pas de responsable ou ne sont pas à jour (beaucoup de contenu non traduit). Merci de contribuer sur Transifex.
Documentation revus et mises à jour disponible.

 

Vous souhaitez découvrir d’autres fonctionnalités GLPI ? : cliquez ici