Formcreator 2.13.1 – corrección de errores

Esta versión es compatible con GLPI 10.0.

⚠️ Debe actualizar desde una versión estable anterior. No se admite la actualización desde una versión de desarrollo o de prueba.

Corrección de Errores

  • inverted existence test on ticket update (2acc5cd4)
  • log more errors, and update obsolete error logging (ae28ed6d)
  • restore page redirections existing in v2.12 (582f926c)
  • update obsolete error logging (da8929e0)
  • abstractitiltarget: glpi 10.0.3 will require a data with a valid value (5f385bb8)
  • actorfield: default value not saved (c3baebbe)
  • actorfield: php warning (6d3e98d1)
  • checkboxesfield: replace div with p in checkbowes answers (9ef95343)
  • composite: php warning breaks JSON if a ticket is not generated (2108983c)
  • descriptionfield: bad form rendering (87a74058)
  • filefield: php error when switching field type to file (a03c7a0a)
  • form: javascript (f05bc697)
  • form: list on self service homepage (ba6d4a58)
  • form: undefined var (169d2c8e)
  • form: url to form answer lists may be invalid (6cd29e6d)
  • install: avoid alter table fail (4dadea8a)
  • install: missing method in upgrade to 2.13.1 (7e9cdcd5)
  • issue: issue not deleted when tichet goes to trash bin (c977b1ca)
  • issue: purge issue when deleting associated ticket (76444ecc)
  • issue: recreate when restore ticket (2656e284)
  • item_targetticket: uuid to ID conversion (e9f326c0)
  • section: name encoding in designer and rendered form» (491dcb69)
  • targetticket: bad constant name (48dda4f3)
  • targetticket: table structure inconsistency (ff56f3f1)
  • targetticket: table structure inconsistency (892a83c3)
  • targetticket,targetchange: tags from queestion or specific tags not saved (ec08d95e)

Características

  • prepare compatibility with PHP 8.2 (#2966) (4bb7f3c3)
  • formanswer,issue: show title in navigation header (1878e4b0)
  • kb: preselect see all categorie (1b669d4f)

Ayuda / Contribución necesaria
Actualizaciones locales: algunos idiomas no tienen mantenedor o están retrasados ​​(muchos contenidos sin traducir). Contribuya en Transifex.

Nueva versión de GLPI 10.0.3

Una nueva versión de GLPI está disponible.

Esta versión soluciona varios problemas de seguridad críticos que se han descubierto recientemente. ¡La actualización es muy recomendada!

Puede descargar el archivo GLPI 10.0.3 en GitHub.
Excepcionalmente, dado que tenemos problemas de seguridad críticos que afectan a GLPI 9.5, también publicamos un archivo de GLPI 9.5.9.

A continuación encontrará la lista de problemas de seguridad corregidos en esta versión de corrección de errores:

  • XSS mediante API de registro (CVE-2022-35945)
  • Fuga de información sensible por error en la página de inicio de sesión (CVE-2022-31143)
  • XSS almacenado mediante búsqueda global (CVE-2022-31187)
  • Inyección de comandos utilizando un script de biblioteca de terceros (CVE-2022-35914)
  • Inyección SQL a través del controlador de plugins (CVE-2022-35946)
  • Autenticación vía inyección SQL (CVE-2022-35947)
  • Falsificación ciega de solicitud del lado del servidor (SSRF) en fuentes RSS y planificación (CVE-2022-36112)

Además, aquí hay una breve lista de cambios principales realizados en esta versión:

  • Comprobaciones de derechos más precisas en el inventario (#12610)
  • Visualización del último valor inventariado para campos bloqueados (#12602)
  • Permiso para usar reglas para agregar computadoras como máquinas virtuales (#12572)
  • Delegar la seguridad de las cookies de sesión al administrador del sistema (#12302)
  • Evitar la falla del recopilador en el encabezado de correo no válido (#12232)
  • Muchas correcciones en el inventario de red

El registro de cambios completo está disponible para obtener más detalles.

¡Nos gustaría agradecer a todas las personas que contribuyeron a esta nueva versión ya todos aquellos que contribuyen regularmente al proyecto GLPI!

Saludos.

Nuevo socio plata: ANC Technology Services S.A (Amvix)

Nos complace anunciar nuestro nuevo socio plata en Costa Rica: ANC Technology Services S.A (Amvix).

ANC Technology Services S.A (Amvix) es una empresa con más de 14 años de experiencia en el mercado. Se especializan en tecnologías OpenSource para implementación de soluciones de red, seguridad, Internet y CRM.

Brindan apoyo en la gestión preventiva, consultoría y dimensionamiento de infraestructuras. Se acercan a las oportunidades de negocio que ofrecen nuevas tecnologías informáticas.

Entre muchas soluciones, ANC Technology Services S.A (Amvix) ofrece:

  • Consultoría y Asesoramiento.
  • Instalación y configuración de servidores Linux.
  • Virtualización de escritorios y aplicaciones.
  • Soporte técnico.

Sitio web: http://www.amvix.com/

Estamos entusiasmados de que la solución ITSM GLPI esté cada vez más representada en todo el mundo y que la red GLPI (nuestra oferta de soporte local: proteja su infraestructura de TI) estará disponible para más clientes a través de nuestros nuevos socios.

Nuestra gran red de socios siempre está abierta a nuevas colaboraciones. Si está interesado en representar uno de nuestros productos en su país, contáctenos: https://glpi-project.org/contact/

Ser socio significa:

  • Tener acceso directo al conocimiento técnico de Teclib;
  • Obtenga descuentos especiales;
  • Tener acceso al soporte oficial,
  • Muchas otras herramientas que lo ayudarán a ganar más clientes y aumentar su reputación en el mercado, agregando ITSM de código abierto a su cartera.

Descubre todos los beneficios de ser socio aquí: https://glpi-project.org/partners/

Formcreator 2.13.0 – ¡versión final!

Esta versión solo es compatible con GLPI 10.

Revisión de la documentación y actualizaciones

Corrección de errores

  • cannot delete a ticket from service catalog (acec9bb8)
  • abstractitiltarget: alternative email lost if no requester user (78fd8450)
  • abstracttarget: uuid should not be updated (b1e492d3)
  • checkboxesfield: avoid HTML br tag (c3a60bbb)
  • condition: compatibility with Advanced forms validation (6685b943)
  • descriptinfield: conversion to target requires escaping (b79cfa95)
  • filefield: mandatory check may cause exception (3f711a54)
  • form: PHP warning (844ef96c)
  • form: bad URL when using advanced form validation plugin (adb9fba5)
  • formanswer: grid style updated for current version of gridstack (85b6a686)
  • formanswer: select inherited class if needed (955dc969)
  • formanswer: update gridstack css (70deaa06)
  • glpiselectfield: missing entity restrict (40c9ab73)
  • install: prevent useless warnings (001d12f5)
  • install: use modern settings for tables (f04e4181)
  • issue: remove duplicate item in status dropdown (27f9f313)
  • ldapselectfield: log LDAP error instead of showing it to user (e170dc6f)
  • ldapselectfield: no translation for items (d170c79c)
  • targetticket: prevent exception in inconsistent target ticket (ba6ed88e)
  • textarea: on change event broken (9fb70edb)
  • textarea: rn chars added between lines (66571b80)
  • textarea, entityconfig: embedded image question description (#2901) (0d78db1a)
  • textareafield: embedded image upload broken (d58075cd)
  • textareafield: missing escape before compare (ba78e935

Características

  • formanswer: order formanswers by date desc (7fdeda51)
  • ldapselectfield: lazy loading (bffcb5b7)

Ayuda / Contribución requerida

Actualizaciones locales: algunos idiomas no tienen mantenedor o están retrasados (mucho contenido sin traducir). Por favor contribuye a Transifex.

Verifique el registro de cambios y descargue

GLPI 10.0.1

Aquí está la primera versión de corrección de errores para GLPI 10.
Puede descargar el archivo en GitHub.

Se han solucionado muchos problemas desde la primera versión de GLPI 10.
A continuación encontrará una breve lista de los puntos clave de esta versión:

  • Correcciones en las reglas de inventario.
  • Correcciones para la función de reserva.
  • Cambio de estado en los objetos de asistencia al modificar actores.
  • Correcciones en la preselección como solicitante en el objeto de asistencia.
  • Se agregó la gestión de bloqueos globales para el inventario.
  • Re-implementación de la acción de adición de documentos en el objeto de asistencia.
  • La función de suplantación de identidad ahora muestra sugerencias si no está disponible.
  • Las actualizaciones con la consola GLPI ahora pueden verificar la integridad de la base de datos.
  • La función GANTT se ha movido a un plugin.
  • La licencia GLPI se ha movido a GPLv3+.

El registro de cambios completo está disponible para más detalles.

¡Nos gustaría agradecer a todas las personas que contribuyeron a esta nueva versión ya todos aquellos que contribuyen regularmente al proyecto GLPI!

Saludos.