Formcreator 2.13.1 – correções de erros

Esta versão é compatível com GLPI 10.0.

⚠️ Você deve atualizar de uma versão estável anterior. A atualização de uma versão de desenvolvimento ou teste não é suportada.

Correção de erros

  • inverted existence test on ticket update (2acc5cd4)
  • log more errors, and update obsolete error logging (ae28ed6d)
  • restore page redirections existing in v2.12 (582f926c)
  • update obsolete error logging (da8929e0)
  • abstractitiltarget: glpi 10.0.3 will require a data with a valid value (5f385bb8)
  • actorfield: default value not saved (c3baebbe)
  • actorfield: php warning (6d3e98d1)
  • checkboxesfield: replace div with p in checkbowes answers (9ef95343)
  • composite: php warning breaks JSON if a ticket is not generated (2108983c)
  • descriptionfield: bad form rendering (87a74058)
  • filefield: php error when switching field type to file (a03c7a0a)
  • form: javascript (f05bc697)
  • form: list on self service homepage (ba6d4a58)
  • form: undefined var (169d2c8e)
  • form: url to form answer lists may be invalid (6cd29e6d)
  • install: avoid alter table fail (4dadea8a)
  • install: missing method in upgrade to 2.13.1 (7e9cdcd5)
  • issue: issue not deleted when tichet goes to trash bin (c977b1ca)
  • issue: purge issue when deleting associated ticket (76444ecc)
  • issue: recreate when restore ticket (2656e284)
  • item_targetticket: uuid to ID conversion (e9f326c0)
  • section: name encoding in designer and rendered form» (491dcb69)
  • targetticket: bad constant name (48dda4f3)
  • targetticket: table structure inconsistency (ff56f3f1)
  • targetticket: table structure inconsistency (892a83c3)
  • targetticket,targetchange: tags from queestion or specific tags not saved (ec08d95e)

Características

  • prepare compatibility with PHP 8.2 (#2966) (4bb7f3c3)
  • formanswer,issue: show title in navigation header (1878e4b0)
  • kb: preselect see all categorie (1b669d4f)

Ajuda / Contribuição necessária


Atualizações locais: alguns idiomas estão sem manutenção ou atrasados ​​(muito conteúdo não traduzido). Contribua no Transifex.

Nova versão do GLPI 10.0.3

Uma nova versão do GLPI está disponível.

Esta versão corrige vários problemas críticos de segurança que foram descobertos recentemente. A atualização é fortemente recomendada!

Você pode baixar o arquivo GLPI 10.0.3 no GitHub.
Excepcionalmente, como temos problemas críticos de segurança que afetam o GLPI 9.5, também lançamos um arquivo GLPI 9.5.9.

Abaixo está a lista de problemas de segurança corrigidos nesta versão de correção de bug:

  • XSS via API de registro (CVE-2022-35945)
  • Vazamento de informações confidenciais devido a erro na página de login (CVE-2022-31143)
  • XSS armazenado via pesquisa global (CVE-2022-31187)
  • Injeção de comando usando um script de biblioteca de terceiros (CVE-2022-35914)
  • SQL injection via driver de plugin (CVE-2022-35946)
  • Autenticação via injeção SQL (CVE-2022-35947)
  • Falsificação de solicitação cega do lado do servidor (SSRF) em feeds RSS e agendamento (CVE-2022-36112)

Além disso, aqui está uma pequena lista das principais alterações feitas nesta versão:

  • Verificações de direitos mais precisas no inventário (#12610)
  • Exibição do último valor inventariado para campos bloqueados (#12602)
  • Permissão para usar regras para adicionar computadores como máquinas virtuais (#12572)
  • Delegue a segurança do cookie de sessão ao administrador do sistema (#12302)
  • Evite a falha do coletor no cabeçalho de e-mail inválido (#12232)
  • Muitas correções no inventário de rede

O registro de alterações completo está disponível para mais detalhes.

Gostaríamos de agradecer a todos que contribuíram para esta nova versão e a todos que contribuem regularmente para o projeto GLPI!

Saudações.

Novo Parceiro Prata: ANC Technology Services S.A (Amvix)

Temos o prazer de anunciar nosso novo parceiro prata na Costa Rica – ANC Technology Services S.A (Amvix).

A ANC Technology Services S.A (Amvix) é uma empresa com mais de 14 anos de experiência no mercado. Eles são especializados em tecnologias OpenSource para a implementação de soluções de rede, segurança, Internet e CRM.

Eles fornecem apoio na gestão preventiva, consultoria e dimensionamento de infra-estrutura. Eles se aproximam das oportunidades de negócios oferecidas por novas tecnologias de computação.

Entre muitas soluções, a ANC Technology Services S.A (Amvix) oferece:

  • Consultoria e Assessoria.
  • Instalação e configuração de servidores Linux.
  • Virtualização de desktops e aplicativos.
  • Suporte técnico.

Websitehttp://www.amvix.com/

Estamos entusiasmados que a solução ITSM GLPI está se tornando cada vez mais representada em todo o mundo e que a Rede GLPI (nossa oferta de suporte para as instalações locais – obtenha sua infraestrutura de TI segura) estará disponível para mais clientes através de nossos novos parceiros.

Nossa grande rede de parcerias está sempre aberta para novas colaborações. Se você estiver interessado em representar um de nossos produtos em seu país, entre em contato conosco: https://glpi-project.org/contact/

Ser um parceiro significa:

  • Ter um acesso direto aos conhecimentos técnicos da Teclib;
  • Obter descontos especiais;
  • Ter acesso ao suporte oficial,
  • Muitas outras ferramentas que o ajudarão a conquistar mais clientes e aumentar sua reputação no mercado, acrescentando o ITSM de código aberto ao seu portfólio.

Descubra todos os benefícios de ser um parceiro aqui: https://glpi-project.org/partners/

Formcreator 2.13.0 – versão final!

Esta versão é compatível apenas com GLPI 10.

revisão de documentação e atualizações

Correções de bugs

  • cannot delete a ticket from service catalog (acec9bb8)
  • abstractitiltarget: alternative email lost if no requester user (78fd8450)
  • abstracttarget: uuid should not be updated (b1e492d3)
  • checkboxesfield: avoid HTML br tag (c3a60bbb)
  • condition: compatibility with Advanced forms validation (6685b943)
  • descriptinfield: conversion to target requires escaping (b79cfa95)
  • filefield: mandatory check may cause exception (3f711a54)
  • form: PHP warning (844ef96c)
  • form: bad URL when using advanced form validation plugin (adb9fba5)
  • formanswer: grid style updated for current version of gridstack (85b6a686)
  • formanswer: select inherited class if needed (955dc969)
  • formanswer: update gridstack css (70deaa06)
  • glpiselectfield: missing entity restrict (40c9ab73)
  • install: prevent useless warnings (001d12f5)
  • install: use modern settings for tables (f04e4181)
  • issue: remove duplicate item in status dropdown (27f9f313)
  • ldapselectfield: log LDAP error instead of showing it to user (e170dc6f)
  • ldapselectfield: no translation for items (d170c79c)
  • targetticket: prevent exception in inconsistent target ticket (ba6ed88e)
  • textarea: on change event broken (9fb70edb)
  • textarea: rn chars added between lines (66571b80)
  • textarea, entityconfig: embedded image question description (#2901) (0d78db1a)
  • textareafield: embedded image upload broken (d58075cd)
  • textareafield: missing escape before compare (ba78e935

Características

  • formanswer: order formanswers by date desc (7fdeda51)
  • ldapselectfield: lazy loading (bffcb5b7)

Ajuda / Contribuição necessária

Atualizações de localidades: alguns idiomas não têm mantenedor ou estão atrasados (muitos conteúdos não traduzidos). Por favor, contribua em Transifex.

Verifique o changelog e faça o download

GLPI 10.0.1

Aqui está a primeira versão de correção de bug para GLPI 10.
Você pode baixar o arquivo no GitHub.

Muitos problemas foram corrigidos desde o primeiro lançamento do GLPI 10.
Abaixo você encontrará uma pequena lista dos pontos-chave desta versão:

  • Correções nas regras de estoque.
  • Correções para a função de reserva.
  • Mudança de estado em objetos de assistência ao modificar atores.
  • Correcções na pré-selecção como requerente no objecto de assistência.
  • Adicionado gerenciamento de bloqueio global para inventário.
  • Reimplementação da ação adicionar documento no objeto de atendimento.
  • O recurso de phishing agora mostra sugestões se não estiver disponível.
  • Atualizações com o console GLPI agora podem verificar a integridade do banco de dados.
  • A função GANTT foi movida para um plugin.
  • A licença GLPI foi movida para GPLv3+.

O registro de alterações completo está disponível para mais detalhes.

Gostaríamos de agradecer a todas as pessoas que contribuíram para esta nova versão e a todos aqueles que contribuem regularmente para o projeto GLPI!

Saudações.